Project

General

Profile

Actions

Bug #57

closed

Bug #80: Version 1.6 bugfixes

dbconvert doesn't get detector sizes right?

Added by Ole Hansen over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
4.00 h
Spent time:
Responsible:

Description

Looks like it converts these old-format data

Half of X, half of Y, full Z sizes (in m) of S1
  0.88  0.18  0.005 - Meters

to these in the corresponding new-format database

L.s1.size = 0.88 0.18 0.01

Something is obviously wrong. The z-value needs to be 1/2 of what it is.

For consistency, we might also want to store full x and y sizes in the database. Internally, we can divide them by 2 and work with half-sizes.

Actions #1

Updated by Ole Hansen over 5 years ago

  • Priority changed from Normal to High
Actions #2

Updated by Ole Hansen over 5 years ago

  • Parent task set to #68
Actions #3

Updated by Ole Hansen over 5 years ago

  • Start date deleted (01/18/2017)
Actions #4

Updated by Ole Hansen about 5 years ago

  • Parent task changed from #68 to #80
Actions #5

Updated by Ole Hansen almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

A little debugging revealed that all new v1.6 databases need to specify detector dimensions as "full" sizes. v1.5 and earlier databases defined the x and y size as "half" sizes, while z was full size. dbconvert simply copied the size values without any modifications, which was incorrect. I fixed this in commit 48849d8. So that was definitely a bug.

However, I could not reproduce the problem described in the description of this issue. The z-size is always correctly copied. Maybe this was a rounding problem due to a leftover output stream state. Since I can't reproduce it, I have to assume it got fixed as a byproduct of further code development. So let's close this issue for now, but keep a note to self to continue checking the dbconvert results carefully as we do further testing.

Actions

Also available in: Atom PDF